Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
RSS-Feed Fehler beim Einsatz von DIVs
29.06.2006, 15:48 PM
Beitrag: #1
RSS-Feed Fehler beim Einsatz von DIVs
Salut,

beim Einsatz von DIVs für die Zentrierung (andere noch nicht getestet) erhalte ich beim RSS-Feed nachweislich einen Fehler.

IE
Zitat:Das Endtag 'description' stimmt nicht mit dem Starttag 'div' überein.

Mozilla
Zitat:XML-Verarbeitungsfehler: Nicht übereinstimmendes Tag. Erwartet: </div>.

Schaue ich mir den Quelltext der Nachricht an, so wird dieser "sauber" mit <div align="center"> begonnen und mit </div> abgeschlossen:

Code:
<div align="center">mittiger Text</div>

Der Quelltext des RSS-Feeds "verschluckt" das schließende </div>:

Code:
<description><div align="center">
mittiger Text
</description>

und bemängelt diesen. Ein Fehler der RSS-Implementierung oder woanders suchen?

Grüße, e2e4
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.07.2006, 07:58 AM
Beitrag: #2
Re: RSS-Feed Fehler beim Einsatz von DIVs
Salut, das Problem besteht immer noch. Kann dies jemand verifizieren und ggf. bestätigen (oder auch nicht)? Smile

Grüße, e2e4
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.09.2006, 11:57 AM
Beitrag: #3
Re: RSS-Feed Fehler beim Einsatz von DIVs
Hallo!

Bin gerade neu hier.

Habe auch dieses Problem:

XML-Verarbeitungsfehler: Nicht übereinstimmendes Tag. Erwartet: </div>.

Würde den Newsfeed gerne nutzen, aber so funzt es leider nicht.

Kann den niemand helfen???

Mit verspielten Grüßen
Peter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.09.2006, 16:47 PM
Beitrag: #4
Re: RSS-Feed Fehler beim Einsatz von DIVs
Moin,

gib mir doch mal die Url zu dem rss Feed bitte.

cu basti

iwebspace.de | Webspaceorder - Bestellsystem für ISP
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.09.2006, 17:14 PM
Beitrag: #5
Re: RSS-Feed Fehler beim Einsatz von DIVs
Hallo!

Hier mal mein Link:

http://www.spiel-zeit-online.de/newswriter/rss.php

Was muß eigentlich bei:

Link zur Seite des Newsfeeds

in den Einstellungen stehen? Der Link zur php Datei???

Außerdem habe ich noch ein Problem, wenn ich im Longtext Links eingeben will.
Es wird immer vor der Linkadresse nochein teil der Adresse mit ausgegeben vom Newswriter Verzeichniss. Dementsprechend werden natürlich im Text keine Links korrekt im neuen fenster dargestellt.

Mit verspielten Grüßen
Peter

http://www.spiel-zeit.de (Newswriter Page)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.09.2006, 19:05 PM
Beitrag: #6
Re: RSS-Feed Fehler beim Einsatz von DIVs
Hi,

Das mit den Links verstehe ich nicht, was genau wird da eingefügt?
Der Link, den du eingeben sollst, ist der zu deiner Seite (also http://www.spiel-zeit.de).

Du hast in deinen News einen Text aus Word eingefügt per copy&paste.
Bitte entferne mal das <p class="MsoNormal"> aus dem Quelltext deiner News und ruf dann noch den rss Feed noch mal aus.

cu basti

iwebspace.de | Webspaceorder - Bestellsystem für ISP
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.09.2006, 20:34 PM
Beitrag: #7
Re: RSS-Feed Fehler beim Einsatz von DIVs
Hallo Sebastian!

Anscheinend hat es tatsächlich an den HTML-Tags gelegen.
Jetzt geht es.

Und mit den Links: Hab eben nochmal ausprobiert. Jetzt geht es.

Gestern, als ich mit dem Editor im Text einen Link eingebaut habe, wurde anschließend in der Nachricht noch ein Teil der Adresse vom Newswriter mit eingetragen vor dem www.

Sah dann so aus:
/newswriter/index.php/www.spiel-zeit-shop.de

Aber jetzt geht es zumindest.

Vielen Dank für die Hilfe.
Also kann man sagen, das man die Texte dort unformatiert bzw. von fremden Code bereinigt reinstellen soll, damit sie im RSS Feed richtig angezeigt werden.

Mit verspielten Grüßen
Peter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.09.2006, 16:08 PM
Beitrag: #8
Re: RSS-Feed Fehler beim Einsatz von DIVs
Hi,

ja der RSS Feed mag leider keine Sonderzeichen, deswegen werden auch Umlaute und dergleichen "umgeschrieben" vom Script.

cu basti

iwebspace.de | Webspaceorder - Bestellsystem für ISP
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.12.2008, 14:48 PM
Beitrag: #9
RE: RSS-Feed Fehler beim Einsatz von DIVs
Wie habt Ihr das Problem mit der Lesbarkeit des RSS-Feeds gelöst? Ich kann die Lösung aus dem Dialog in diesem Threat nicht nachvollziehen. Ich habe derzeit auch das Problem bei einem System für einen Kunden: http://www.humancaps.de/cms_1-5/rss.php
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.12.2008, 15:15 PM
Beitrag: #10
RE: RSS-Feed Fehler beim Einsatz von DIVs
Bitte nicht in zwei Threads das gleiche Problem posten.

cu basti

iwebspace.de | Webspaceorder - Bestellsystem für ISP
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  RSS-Feed fehlerhaft wurzer 13 18,800 22.12.2008 14:39 PM
Letzter Beitrag: wurzer
  Fehler in der Funktion &quot;tellafriend&quot; brummi 2 4,907 01.05.2007 12:57 PM
Letzter Beitrag: cebner
  Sonderzeichen Fehler im Newswriter ! elacqua 9 13,094 04.03.2007 18:58 PM
Letzter Beitrag: cappo
  Fehlermeldung beim einfügen/bearbeiten von neuen Artikeln Gingko 10 11,944 01.10.2006 17:50 PM
Letzter Beitrag: basti
  Problem beim einfügen von Texten bfkgmunden 1 3,780 04.05.2006 20:33 PM
Letzter Beitrag: bfkgmunden
  Template-Funktion TinyMCE_advanced_getEditorTemplate Fehler e2e4 13 14,599 05.01.2006 18:15 PM
Letzter Beitrag: e2e4
  Bild auf Nachrichtenseite -&gt; Bildarchiv -&gt; Fehler auf XrtdFozzibaer 13 14,152 29.08.2005 15:34 PM
Letzter Beitrag: basti
  Fehler beim löschen von Artikeln ohne separater Seite fbegemann 6 7,633 24.05.2005 09:58 AM
Letzter Beitrag: basti
  Kleines Problemchen beim Anzeigen von Bildern PeterB 48 47,431 19.04.2005 12:36 PM
Letzter Beitrag: basti
  Komische zeichen beim erstellen von Texten Brecherle 3 5,248 25.02.2005 14:26 PM
Letzter Beitrag: Brecherle

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste

Kontakt | faqboard.info | Nach oben | Zum Inhalt | Archiv-Modus | RSS-Synchronisation